注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

面朝大海 春暖花开

 
 
 

日志

 
 

易语言编程实现开机自启动功能  

2012-01-12 16:55:07|  分类: 易语言 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
方法很简单,可以写注册表添加:具体命令如下,
.版本 2
.子程序 __启动窗口_创建完毕
写注册项 (#本地机器, “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\” + 取执行文件名 (), 取运行目录 () + “\” + 取执行文件名 ())
这样一句简单的命令就实现了开机自启动,不过你仔细看看,里面的是 取运行目录 () + “\” + 取执行文件名 ()
就是说在开机自启动的目录在你运行的那个目录里,如果你运行后想删除这个文件,你可以这样写,
.版本 2
.支持库 shell
.子程序 __启动窗口_创建完毕
.如果 (文件是否存在 (取特定目录 (#Windows系统目录) + 取执行文件名 ()) = 真)
    写注册项 (#本地机器, “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\” + 取执行文件名 (), 取特定目录 (#Windows系统目录) + 取执行文件名 ())
.否则
    复制文件 (取运行目录 () + “\” + 取执行文件名 (), 取特定目录 (#Windows系统目录) + 取执行文件名 ())
    写注册项 (#本地机器, “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\” + 取执行文件名 (), 取特定目录 (#Windows系统目录) + 取执行文件名 ())
.如果结束
  评论这张
 
阅读(4603)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018